1

I just tried to vote, and after I click my first (or second) choice, nothing happens (I have always voted, so I know that the choices are supposed to be highlighted).

I'm using Safari 9.1.1 at a Mac using OS X 10.9.5

EDIT: It is definitely a bug if using Safari. I tried with Google Chrome 66 Mac and it worked.

1

Step 1: No class is added

Could you open dev tools on the election page and look at the classlist of the button you clicked? It should say selected-choice if you clicked it. I would assume, although this is uncertain, that your vote has come through if you're seeing this class and it is just a rendering issue.

selected-choice class

Step 2:

Open up dev tools again, and select the button and click 'Event listeners'. is there an event listener attached to the button? If so, click through to the JS file by clicking the underlined link after the event listener name (in this case 4:718)

event listener

  • It doesn't add the class; also I know this wasn't going to, because when you vote, your choices are gathered at the right column. – jackJoe May 22 '18 at 13:34
  • Hmpf, strange, I can't find anything on this in the SE meta either. Could you maybe join us in chat to help clarify the issue? – PieBie May 22 '18 at 14:58
  • 3
    I tried with Chrome and it worked, it is definitely a bug with Safari. I won't do any further testing. BTW, thank you for your help and dedication! – jackJoe May 23 '18 at 10:08
  • No prob. I'm leaving this open for now, as some dev from SE might actually pass along triggered by the bug tag – PieBie May 23 '18 at 12:32
  • I tried it on Safari and didn't have an issue. status-norepro – WELZ May 23 '18 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .