10

The use of bold and italic has lost its meaning in the main and meta site. You get text but bold and italic are no longer any different from the main text.

This seems to be a bug! This should be emphasised possibly like italics and bug should be ephasised as bold. Obviously it is fine if these get a new meaning such as color or something but right now the css is a bit messed up.

Or is it really the intention to remove hierarchy out of text?


After looking into this-

It seems to be a problem with the browser or font, since the tags and even CSS is in place. Could it be that the bold font is not for some reason reachable? It works fine on other sites.

I am using Firefox 54.0 on a windows.

15
  • 2
    Works fine for me. I see bold and italics in your post.
    – Wrzlprmft Mod
    Commented Jun 17, 2017 at 7:59
  • Does not seem to work on my system @Wrzlprmft
    – joojaa
    Commented Jun 17, 2017 at 8:03
  • 2
    I don’t doubt that, but if it’s system-specific, it probably helps to provide more information for the developers to track the bug.
    – Wrzlprmft Mod
    Commented Jun 17, 2017 at 8:05
  • 2
    Works fine here. Probably a font issue?
    – Cai
    Commented Jun 17, 2017 at 8:28
  • I am also devoid of bold and italics and that is extremely annoying. W8 FireFox here, and iirc my W10 machine also has this bug in FF
    – Vincent
    Commented Jun 26, 2017 at 15:15
  • Missing both too. W10 • Firefox
    – johnp
    Commented Jun 30, 2017 at 6:56
  • @Vincent I see your bold and italics just fine. But on every other stack exchange except for GraphicDesign, bold and italics don't work for me. Chrome 54 OSX Commented Feb 9, 2018 at 16:39
  • Can't suggest edit here. You should tag this question as design since it's related to site design.
    – iBug
    Commented Feb 20, 2018 at 6:00
  • @iBug done as per request
    – joojaa
    Commented Feb 20, 2018 at 6:02
  • Not just a problem in Firefox. Also in Chrome and Safari on a Mac.
    – Confused
    Commented Mar 3, 2018 at 4:42
  • This is an old, old problem that just keeps rearing its head in different scenarios; see also Roboto on Ubuntu. Ideally, your browser will choose a font that matches what the page calls for, but this seems to break if you have the family but not all the faces.
    – Shog9
    Commented Mar 5, 2018 at 17:14
  • @Shog9 how can i have terrible versions if i load the same fonts as the web page is asking for?
    – joojaa
    Commented Mar 5, 2018 at 17:15
  • @Shog9 couldn't you guys rename the font then it would always use your version?
    – joojaa
    Commented Mar 5, 2018 at 17:27
  • I believe it is possible to tweak the import rules to avoid this, @joojaa... But I'm inclined to consider it a browser bug; if you have the faces installed locally, it should use them and if you don't it should load them not substitute. Also, I've asked the design team to look into this before and it reappeared anyway, so my inclination here is that we're chasing a moving target.
    – Shog9
    Commented Mar 5, 2018 at 17:58
  • @Shog9 but its appearing on many browsers, but yeah ill live, i just renamed my fonts.
    – joojaa
    Commented Mar 5, 2018 at 18:01

3 Answers 3

8

Ok, i tracked the problem down. It appears that the style sheet uses the local version of the font if present. For some reason Firefox does not recognize the boldness in this case.

I am still trying to figure out if it is a problem with the CSS or if it is a bug in the firefox implementation or possibly version of font.

6
  • 1
    confirmed in FF54 on Win10 with Open Sans installed locally
    – PieBie Mod
    Commented Jun 26, 2017 at 15:18
  • 4
    It's not only FF and Windows... ANY locally installed version of OpenSans can conflict in several browsers. Had the same issue on a Mac with Google Chrome.
    – Scott
    Commented Jan 25, 2018 at 20:07
  • The answer is delete the local version of OpenSans. More info here.
    – iBug
    Commented Feb 20, 2018 at 3:20
  • @iBug yes thats what I did. However its not really a solution as then i van not use open sans in projects which means i can not use Graphic design when I do graphic design. See the problem...
    – joojaa
    Commented Feb 20, 2018 at 5:55
  • 1
    yeah that's super inconvenient for graphic designers. One can't delete a font just to visit a website, even if it's a frequently visited/important one.
    – iBug
    Commented Feb 20, 2018 at 5:59
  • Also confirmed for Windows 10, Chrome latest. I thought it was just me!
    – Yisela
    Commented Feb 20, 2018 at 12:19
3

Clear Solution:

(for everyone redirected here)

Uninstall (or disable) OpenSans on your local machine.

To uninstall OpenSans from Windows, open Control Panel → Apperance and Personalization → Fonts. Look for OpenSans and hit "Delete" in the right-click menu.

Click to see full image

Read more on Meta.SE

4
  • How exactly does that solve my need to use open sans in illustrator?
    – joojaa
    Commented Feb 28, 2018 at 14:02
  • 1
    It doesn't (I want to use it too) this is just an answer with the actual solution to get Bold and Italic to work on SE (there are about 6 other sites that also use it) A post was made on meta and it keeps on coming up, so this is just a clear out solution for those who get forwarded here.
    – Welz
    Commented Feb 28, 2018 at 14:04
  • Well i am really avoiding open sans becasue of this (or actually i just renamed the font), but still id like to use it as is.
    – joojaa
    Commented Feb 28, 2018 at 14:07
  • 1
    Or use a font manager and enable/disable as needed
    – Cai
    Commented Mar 1, 2018 at 9:04
2

Confirmed on FF58 (Win7) -- looks like a bug from here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .